
1

Notes

1-Approaches (advantages & disadvantages)اسالیب التعامل مع المسائل
Experimental.خاص مضبوط ولكن یحتاج اجھزة وكلفة ودقة وامان ووقت طویل
Theoreticalعام دقیق ولكن للمشاكل او المسائل البسیطة.
Numerical(Program or Package) واسع التطبیق وكلفة ووقت وخطورة اقل ولكن معقد

وتقریبي.
؟ (Packages)ھذه البرامجملماذا نستخد-2

المعرفة قبل التنفیذ او -تعلمّ برامج رسم وتصمیم ومحاكاة متطورة وقابلة للتعدیل او التغییر في اي وقت ج: 
فھم ما یحصل فعلاً داخل –تعدد الحالات –ربط اكثر من عِلم –توقع ما حصل او سیحصل –استحالة التنفیذ 

.واكثر بكثیرالتي قمت بدراستھاتحوي على كل العلوم –المنظومة 
Computer Aidedالمادة -3 Design  /SolidWorks2014

& Homework)اسبوع وستكون ھناك واجبات 30المحاضرات (تفاعلیة) داخل المختبر اقل من -
Classwork) وتسُمّى نشاط مختبري وتجمع وتقسّم على عدد الواجبات وتسلمّ في كل اسبوع، ولا یقُبل ،

رغبة الطالب زیادة ، وفي حال 10بدل الـ 5التأخیر الاّ بعذر رسمي، اما بدون عذر فیصُلحّ الواجب البدیل من 
الدرجة فیكُلفّ بواجب اضافي یحُدد من قبل الاستاذ المشرف.

توزیع الدرجات:-

دروس التقییم المستمر ذات المختبر

الدرجة النھائیةالسعيامتحان مختبرالفصل الثانيالفصل الأولالموضوع نشاط مختبريامتحاننشاط مختبريامتحان
CAD10%10%10%10%10%50%50%

Word, Powerصیغة المحاضرة: - Point, PDF, Movies, Pictures, Lectures, Books,
Examples, Solved Cases, Questions and Solutions, …etc.

مع اسئلة السنوات السابقة والواجبات الصفیّة والبیتیة(C)في الـ المختبركل ھذا موجود على حاسبات-
.Facebookاما التبلیغات والمستجدات فتكون على الـ IDriveSyncالخزنموقعوكذلك على 

ما مطلوب من الطالب:-4
جیدة وسریعة.شخصیةحاسبة-
لنقل اي شيء من حاسبة المختبر.فلاش رام-
(بدون ربط انترنیت مباشر).على الحاسبة الشخصیةتنصیب البرنامج-
التواصل عبر الفیسبوك: -

: التاليالایمیلوكتابةفیسبوكفيالبحثمیزةخلالمنCae Cad Groupالحسابعنابحث-أ
caecadgroup@gmail.com

المرحلة والاختصاص والشعبة فیھاتذكررسالةارسالمعالفیسبوكعلىكصدیقالحساباضف-ب
.الاسماءقائمةمنعلیكالتعرفیتمكيالثلاثياسمكو
.المجموعةالىضمكوثمالاضافةبقبولالمادةتدریسیياحدیقومسوف-ج

الواجبات الصفیّة والبیتیة لكل طالب على حاسبتھ في المختبر التي تحمل رقمھ في قائمة الحضور بإسم خزن -
projectعلى الـ(D) حافظة بالمرحلة وتكون داخل الثلاثي اسم الطالبتسلسل وداخل حافظة تحمل

في المثال كما ویكون ھذا ھو السیاق في الامتحانات ایضاً.،كلھا باللغة الانكلیزیةوالتخصص والشعبة
:التالي
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D:\ 3rd Year \ GE-A or -B (or AC-A or -B or AU or AE) \ 1Ahmed Mustafa Mohammed
\ project1 (HW or CW).

5-CAD :
- (Computer Aided Draughting/Design)
• Creation of 3D ‘virtual’ models
• Creation of 2D drawings
• Creation of 2D drawings from 3D models
• Simulation of behavior
• Simulation of real life appearance
• Assist in manufacture
- Advantages:

 Easier creation and correction of drawings
 Better visualization of drawings
 Quick and convenient design analysis
 Simulation and testing of designs (stress)
 Increased accuracy
 Improved filing system of the drawing (Hard disk)
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للحافظاتاستعراض
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التنصیب: -6
جد تعلیمات خاصة موضّحة یعتمد على الاصدار ، وفي كل اصدار توSolidWorksخطوات تنصیب برنامج الـ 

داخل حافظة المحاضرات.solid work setupبالتفصیل ، وھي عبارة عن صور في الحافظة 

منھاج:ال-7

Introduction to CAD and parametric modeling
- Basic Concepts - parts - assemblies - drawings1

Sketching

- Sketch Tools  Toolbar - Edit Sketch
2

2D to 3D Conversion
- 2D to 3D Conversion Overview - 2D to 3D Toolbar3

Reference Geometry
- Reference Geometry Overview - planes - axes - coordinate
systems

4

3D curves
- Projected Curve- Composite Curve- Helix and Spiral5

Features
- Base/Boss, and Cut - Extrude - Revolve - Sweep and Loft -
Fillet/Round - Chamfer and Draft - An application - Pattern
and Mirror - Hole Wizard - Shell - Rib - Dome
- An application

6, 7, 8,
9, 10,

11, and
12

Part properties
- Editing - moving copying, - color13

Equations
- Applying equations14

Dependency
- Geometric Dependency15

Assemblies
- Adding assembly components - Assembly mating - Working with
sub-assemblies - Smart Fasteners - An application

16, 17,
18, and

19
Drawings
- Creating a Drawing - 2D sketching in drawings
- Creating standard views (named views and standard 3 views)
- An application

20, 21,
22, and

23

Detailing
- Detailing tools

24

Files
- Importing and Exporting Files25

Analysis
- Basics and Cosmos Express - Stress analysis

26
and 27

Design project
- Machine design project for each student

28, 29,
and 30
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:مقدمة-8
- What is SolidWorks؟

 •SolidWorks is design automation software.

•In SolidWorks, you sketch ideas and experiment with different designs to create 3D
models.

 •SolidWorks is used by students, designers, engineers, and other professionals to
produce simple and complex parts, assemblies، and drawings.

- Benefits of solid modelling:

•Solid modelling enjoys many benefits not offered by 2D design methods.

•The solid model has a volume and surfaces.

•The solid model can easily be analyzed for its physical properties, such as volume, mass,
surface area, cross sectional areas, location of center of mass, moments of inertia, etc.

•The 3D environment offers excellent visualization of the design as a shaded solid, with
texture and color, or as a wire framed representation.

برامج الرسم الھندسي:ھناك نوعان من 
a. Parametric (Geometry drives dimensions)
b. Non-Parametric (Dimensions drives geometry)

- SolidWorks is a fully parametric CAD program.

•This means that when a part is designed and modeled dimensions are assigned which
define the part. If, at a later time, these dimensions are found to be unsuitable they can
be easily changed and the modification will filter through the system wherever the part
appears.

•This is particularly helpful when dealing with an assembly since, if a modification is
made to a single part, the modification is carried throughout the assembly.

•A designer can also define relationships between parts. For example, in an engine, if the
diameter of the piston is increased or decreased, the corresponding engine block can be
defined such that it is automatically modified to match the specifications of the modified
piston.
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- The SolidWorks Model:

The SolidWorks model is made up of:

•Parts

•Assemblies

•Drawings

رسم -3او   رسم اشكال ثم مسح الزائد-2او  تجمیع الخطوط-1رسم: بدایة في الوتوجد اكثر من طریقة لل
، وفي كثیر من الاحیان نستخدم ثلاثتھا معاً.جزء وعمل نسخ لھ اذا كان متناظر



9

- Solidworkds Menu

- CommandManager

To toggle the descriptions and size of the buttons, right-click in the
CommandManager and select or clear Use Large Buttons with Text.

- Sketcher

- Features

- Head Up View Toolbar
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- Manipulating the display using the Mouse

- FeatureManager Design tree

- SolidWorks provides tutorials

•http://www.solidworkslessons.info/#
•http://www.aboutsolidworks.com/solidworks_tutorials.htm
•YouTube



Tutorial 1: SolidWorks User Interface
SolidWorks User Interface is pretty simple and straight forward. There is 6 main area of
interface you normally work with.

1) Menu Bar – Top most of the application, executing New File, Open File, Save, Print,
Undo, Select, Rebuild, File Properties and Options.

2) Command Manager – Access to part, assembly and drawing editting tools.



3) Feature Manager design tree – Outline overview how your part, assembly and
drawing constructed.



4) Status bar – Provide an information about your part, assembly and drawing.



5) Head up view toolbar – View tools such as zoom, pan, zoom plane and section view.



6) Graphics area – Workspace for your part, assembly and drawing.





Introduction to SolidWorks
Solidworks Overview
Solidworks main idea is user to create drawing directly in 3D or solid form. From this
solid user can assemble it directly on their workstation checking clashes and
functionality of it. Creating drawing is pretty easy just drag and drop the solid to

drawing block.

Part
Part is created by sketch.



Sketch is the base to define your part, form and features.

Before you start creating sketches you must select plane or face where the sketch will

be place on.



After select plane or face the sketch will be, sketch on it!

When you done with sketch, adding features it is your next step. Select

Feature>Extruded Cut



Select Through All and OK.

Assembly
Assembly is how all parts works together in assembly, checking for clashes and it
functionality. First all parts inserted in assembly by Insert Component tool.



When all parts inserted into workspace, Mate is command to define how parts mate

with each other.

Let’s mate this block and pin together, click Mate and select pin face and hole face, OK.

Drawing



Drawing is use for detailing part by adding dimension to it. To create a drawing first you
need to select drawing block.

When block inserted, select click view palette to add drawing view.

Choose the part you wish to make drawing.



Now just drag and drop the part view on drawing block and add dimensions.



Summary
Solidworks works by it user creating part in 3D or solid form. Three solidworks
component is Part, Assembly and Drawing. Part define by it sketch and selected
feature. Assembly is how all parts assemble in one unit, parts assemble by user adding
mate between parts. Drawing is for detailing and adding dimensions to part.





How to create simple box

1. Click New , Click Part and OK.
2. Click on Top Plane and click Sketch.

3. Click Rectangle , sketch a rectangle start from origin.

4. Click Smart Dimension , click side edge and click top edge to dimension it
as 1.0in x 1.0in.



5. Click Features>Extruded Boss/Base

set D1 as 1.0in

and click .

6. It’s done.





How to create simple plate

1. Click New (File>New) , click Part , OK.

2. Click Option (Tools>Option…) , select Document
Properties tab. Select Units , under Unit System select
IPS (inch, pound, second) OK.

3. Select Top Plane , from lower left menu select
Normal To.



4. Click Sketch in Command Manager, click

Rectangle . As you can see on upper right
corner sketch icon appear indicate that you’re on

sketch mode .



5. Pick Origin point as starting point, drag to right

hand side no need to be exact the
size will define in later step. Press keyboard ESC to
end rectangle sketch.

Note: There is two type line generated by your
sketching, the one with black line and blue line. Black
line is line that fully defined and blue line is under
defined.

6. Define sketch with dimension. Click Smart

Dimension , and start dimensioning pick
vertical line and set to 2.00in , pick horizontal line and

set to 2.00in . Press keyboard ESC to
end smart dimension



7. Build feature from sketch, click Features

and activate features menu. Click Extruded

Boss/Base and set D1 to 0.5in

and .

8. Click front top face , click

Normal To . Activate sketch menu by



click Sketch and select Circle . Sketch

4 circle at four edges.

9. Define new circle sketch, click Smart Dimension

, set diameter circle to 0.2in . Select distance

for edge set to 0.3in .



10. Click Circle and sketch one circle at center

.

11. Define new circle sketch, click Smart

Dimension , set diameter circle to 1.0in .
Select distance for edge set to

1.0in.



12. For cut click Features , click Extruded Cut

, under Direction 1, Through All

and .

Done.



How to create Allen key

In this Solidworks tutorial, you will create simple allen
key.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

3. Click Line, skecth a L shape.



4. Click Smart Dimension, and dimension sketch
as 2.5″ and 1″.

5. Click Sketch Fillet, add 0.3″ fillet at L corner.



6. Exit sketch, click on Top Plane and
click Sketch.

7. Click on Sketch2 and click Normal To.

8. Click Polygon, sketch a polygon at origin.

9. Click Smart Dimension, and dimension sketch
diameter to 0.15″.



10. Exit sketch, click on Isometric view.

11. Click Features>Swept Boss/Base,
for profile click on Sketch2 and for path click
on Sketch1 and OK.



You’re done!.



How to create 17 inch car wheel

1. Create a skecth as show on Front Plane.



2. Revolve sketch, 360 degree on top sketched line

. OK.

3. Create circle skecth, on right plane 4.8in



, extrude 2in

OK.



4. Insert sketch on edge wheel face, skecth for arm

hole , extruded cut ,
through all, OK.

5. Add fillet R0.5in inner , add fillet

0.2in OK.

6. Click Circular Pattern , click View>Temporary
Axes, select center axis as rotation axis. 360 degree



and #5 equal spacing

. Select Cut-Extrude1, Fillet1
and Fillet2 as a Features to Pattern. OK.

7. Select hub face, click Hole Wizard , select Ansi
Inch, Hex Bolt, size 1/2, through all. Position point at



diameter 4in and 36 degree .
OK.

8. Click Circular Pattern , select center temporary
axis, 360 degree and #5 equal spacing. Select CBORE
for 1/2 Hex Head Bolt as Features to Pattern. OK.



9. Add chamfer 0.5in to hub side.

10. Click on hub face, insert skecth, sketch circle

diameter 2.75in. Extrude Cut to 0.5in deep.



11. Add chamfer 0.5in to inner cut

and add chamfer 0.25in to

wheel edge , OK. Done.



How to create simple sheet metal bend

In this tutorials you will learn how to utilize
sheetmetal tool such insert bend and flaten.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

Use Line , sketch L shape. Dimension sketch

with Smart Dimension as 1in x 1in.



3. Click Offset Entities and click L sketch. Set
offset distance as 0.1in.

4. Use Line , sketch and connected open end of this
sketch and make it close both end.



5. Click Features>Extruded Boss/Base
set D1 to 0.5in and OK.

6. Click Sheetmetal>Insert Bends, click flat face
as reference when it flatten. Set bend radius
to 0.03in and K factor 0.5 and OK.

7. Your simple sheetmetal bend is ready. Look at part
tree.



8. To view this part in flatten form
click Sheetmetal>Flatten.

Have fun.. If you cannot find the sheetmetal tool in
you main tool menu, you can right click on main
menu tab and check Sheetmetal option.



You know the basic, try model this bracket.

No idea? Wait for this SolidWorks tutorial on my next
post..



How to create spring

1. Click New (File>New) , click Part , OK .

2. Click Option (Tools>Option…) , select Document
Properties tab. Select Units , under Unit System select
IPS (inch, pound, second) OK.

3. Select Top Plane , from lower left menu select

Normal To.



4. Click Sketch in Command Manager, click

Circle . As you can see on upper right corner
sketch icon appear indicate that you’re on sketch

mode .

5. Pick Origin point as starting point, drag to right

hand side no need to be exact the size
will define in later step. Press keyboard ESC to end
circle sketch.

Note: There is two type line generated by in
sketching, the one with black line and blue line. Black
line is line that fully defined and blue line is under
defined..

6. Define sketch with dimension. Click Smart

Dimension , and start dimensioning pick circle



edge and set to 0.50in . Press keyboard
ESC to end smart dimension.

7. Change display to Isometric

view.

8. Insert coil, Click

Insert>Curve>Helix/Spiral
.



9. Press F to zoom fit, set Parameters Constant Pitch ,
Pitch 0.10in Revolutions 4 , Start angle 0.0deg

and .

10. Click to Right Plane , click Normal

To .

11. Click Sketch , click Circle . Sketch circle at start
point, then click Smart dimension set circle diameter
to 0.05in



.

12. Click exit sketch . Click Features

and activate features menu. Click Swept

Boss/Base and set Profile to Sketch2 by click

on circle sketch and
set Path by click helix path

and .



13. Change display to Isometric

view.

14. Press F to zoom fit.

Done. Pat yourself on back.



How to engrave text to part

1. Click New (File>New) , click Part , OK .

2. Click Option (Tools>Option…) , select Document
Properties tab. Select Units , under Unit System select
IPS (inch, pound, second) OK .

3. Select Top Plane , from lower left menu select

Normal To.



4. Click Sketch in Command Manager, click

Rectangle . As you can see on upper right
corner sketch icon appear indicate that you’re on

sketch mode .

5. Pick Origin point as starting point, drag to right

hand side no need to be exact the
size will define in later step. Press keyboard ESC to
end rectangle sketch.

Note: There is two type line generated by your
sketching, the one with black line and blue line. Black
line is line that fully defined and blue line is under
defined.



6. Define sketch with dimension. Click Smart

Dimension , and start dimensioning pick
vertical line and set to 2.00in , pick horizontal line and

set to 2.00in . Press keyboard ESC to
end smart dimension.

7. Build feature from sketch, click Features

and activate features menu. Click Extruded

Boss/Base and set D1 to 0.5in

and .



8. Click front top face , click

Normal To . Click Tools>Sketch



Entities>Text…



9. Input text in text box , to change
font type and size uncheck use document font

. Click



Font… set height to
Points 10 OK.

10. Click to part face to relocate text to center

.

11. To engrave the text, click Features , click

Extruded Cut , under Direction 1 Blind, set D1



to 0.01in and . Click

Isometric from lower left view menu.

Done.



How to create hex bolt

1. Sketch a polygon with 6 side, Tools>Sketch

Entities>Polygon set diameter to

0.75in.



2. Extrude sketch to 0.34in.

3. Create minor diameter for thread, sketch circle on

top face, set diameter to 0.4in.

4. Extrude sketch to 1.1in.



5. Click end edge of thread shaft, click

convert entities .



6. Select Helix/Spiral feature set height to 1.2in,

theap per inch=pitch 13/1in

Ok.



7. Right click on Front plane, Insert sketch

sketch thead profile.

8. Click sweep feature , select
sketch profuile as sketch and helix as a path, OK.



9. Create skecth a circle on the end shaft,

extrude cut 0.1in .

10. Finish.





How to create helical gear

In this solidworks tutorial, you will create helical gear.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

3. Click Circle and sketch a circle center at origin.

Click Smart Dimension, click sketched circle and
set it diameter to 1.0in.



4. You just completed your sketch, let’s build feature

from it. ClickFeatures>Extruded Boss/Base.

Set D1 to 0.3in and .
5. Click on front face and click Normal To.

6. Click on front face and click Sketch.



7. Click on Centerline and sketch vertical
Centerline.

8. Click Line and sketch gear teeth profile.

9. Click Smart Dimension, dimension sketch as
sketched below.



10. Click Exit Sketch, change view
to Isometric.

11. Click scroll mouse button and rotate the part to
back side.



Click the back face and select Normal To. Click on
this face again and click Sketch.

12. We will trace last sketch to this face, while
holding CTRL click all sketched line

and click Convert Entities . Now we
need removed all relation between this sketch and the



other sketch, clickDisplay/Delete Relations
click Delete All

and .

13. Click and drag select all the sketch line.

Click on Rotate Entities,

Click Center of Rotation box



and click origin (center part).

On Parameter option enter 10 deg rotation.

and .

14. Click Exit Sketch, change view
to Isometric.



15. Click Features>Lofted Boos/Base,

open up part tree and double
click Sketch2 and Sketch3 to add for lofted features.



Make sure two green point is at the same edge as
other sketch, if not drag and relocate it.

and .



12. Click on Loft1 (gear teeth) and

click Circular Pattern.
Click on the cylinder face as axis of rotation (or click
on View>Temporary Axes select the temporary axis
as axis of rotation).

Set Instances to 22 and .



13. Click on Front face and select Normal To.

14. Click on front face and select Sketch.



15. Sketch a Circle and sketch a circle center at

origin. Click Smart Dimension, dimension sketch
as 0.40in circle.

16. Click Features>Extruded Cut and
set Direction to Through All and .
17. Click on front face and select Sketch.

18. Click Rectangle and sketch a rectangle as

sketched. Click Smart Dimension, dimension
rectangle as skecthed below.



16. Click Features>Extruded Cut and
set Direction to Through All and . You’re done!



How to create Airplane wings

Last week my friends ask me how to model RC
(remote control) wings in solidworks? He tried to
model by extruding the sketch but it didn’t reflect
what the real wings. So he email me this picture of RC
wings for me to look at. After reviewing the wings
shape, I told him he can model these wings by loft
features. Let’s model these wings together.

1. Click New, Part and OK.
2. Click on Right Plane and click Sketch.

3. Sketch a center aerofoil profile at this plane.



Click Line, sketch a horizontal line, click Smart

Dimension and dimension the line as 6in.

4. To create top curve of aerofoil, click Spline, and
sketch top curve as sketched below, to end Spline
press Esc key.

Exit the sketch.
5. For another aerofoil profile at wing tip, you need to
create another plane. Click onRight Plane

and click Reference Geometry>Plane

set distance between plane as 10in

and .
6. Click on Plane 1 and click Sketch.



7. Click Line, sketch a horizontal line on same level
as first sketch a bit off set from origin,

clickSmart Dimension and dimension sketch as
sketched below.

8. To create top curve of aerofoil, click Spline, and
sketch top curve as sketched below, to
end Spline press Esc key.

Exit the sketch.
9. Click View Oreintation>Isometric.



10. Click Features>Lofted Boss/Base,

click Sketch1 and then Sketch2.

and .

11. To hide Plane 1, click Plane 1 and click Hide.



12. Now let make the full wings, click on Mirror.
Turn the wings to right side and select center
face as a Mirror Face/Plane.

Click on wing body as Features to Mirror

and .

13. You’re done.





How to create turbo fins

1. Skecth 3in circle and extrude to 0.08in on front

plane.



2. Skecth 0.6in circle on top extruded face and exrude

to 1.5in.

3. Sketch fin profile at extruded face as shown and

extrude to 0.6in.



4. Add Plane 1 with 0.68in offset from
Front plane and Plane 2 with 0.85in from Plane 1.



5. Insert sketch on Plane 1, select all edges to
extruded fin and convert it to entities.

6. Insert another sketch on Plane 2, as shown.



7. Sketch two curve line using 3D sketch tool, as

shown.

8. Click Lofted Boss/Base , select profile

Sketch 5 and sketch 6 and for guide
curves select 3DSketch1 and 3DSketch2

, OK.



9. Click Circular Pattern , view
temporary axis Tools>Temporary Axes. Select center
axis, 360 degree, #8, Equal Spacing, OK

. Done!



How to create U bracket sheetmetal

In this tutorials you will learn how to create U bracket
sheetmetal.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

Use Line , sketch U shape. Dimension sketch

with Smart Dimension as 1in x 1.5in x1in and
1.5in height.



3. Click Offset Entities and click U sketch. Set
offset distance as 0.1in, check Reverse box and OK.

4. Use Line , sketch and connected open end of this
sketch and make it close both end.



5. Click Features>Extruded Boss/Base
set D1 to 1in and OK.

6. Click View>Bottom

click on bottom face and click Sketch.



7. Click Circle and sketch 2 circle on bottom face

each side. Use Smart Dimension to dimension
this sketch as sketched below.

8. Click Features>Extruded Cut and
cut Through All this circle.

9. Click View>Isometric.



10. Click Fillet , check box Full round fillet.

11. Click side left side face as Side Face 1.

12. Click on purple box and click center face
as Center Face Set.



13. Click on pink box and click right side face as Side
Face Set2 and OK.



14. Repeat step 11 – 13 for the other side.

15. Repeat step 11 – 13 for inner face and outer
face of U bracket.



16. Click Sheetmetal>Insert Bends, click flat
face as reference when it flatten. Set bend radius
to 0.03in and K factor 0.5 and OK.



17. Your simple sheetmetal bend is ready. Look at
part tree.

18. To view this part in flatten form
click Sheetmetal>Flatten .



Have fun.. If you cannot find the sheetmetal tool in
you main tool menu, you can right click on main
menu tab and check Sheetmetal option.



How to create bottle cap

I get this idea from my medicine bottle cap, the tips
here show you how you can use extrude up to the
face function.

1. Click New , Click Part and OK.
2. Click on Top Plane and click Sketch.

3. Click Circle and sketch start at Origin,

click Smart Dimension and dimension the circle
as 1.0in diameter.



4. Click Features>Extrude Boss/Base set the
D1 to 0.5in

and .

5. Click Fillet , set fillet size as 0.1in, select top
face of the part

and .

6. Turn the part to view bottom side, set D1
as 0.05in, click Shell , select bottom face



and .

7. Click Isometric View , click on Front Plane

and click on Reference Geometry>Plane.

Set distance to 0.65in



and .

8. Click Plane1 and click Sketch.

9. Click Rectangle , sketch on Plane1 as sketched
below and use Smart Dimension for your
dimensioning.

10. Click Features>Extrude Boss/Base set
the Up To Surface



and .

11. Click Fillet , set fillet size as 0.1in, select side
edge of the lid.

and .

12. And you’re done!





Solidworks Tutorial #1: How to create USB head

You can find almost all PC devices having USB feature, let’s 
model one…

1. Click New,  click Part, OK.

2. Click on Top Plane and click Sketch.

3. Click on Rectangle tools and select Center Rectangle,

Click on origin as it center and sketch a rectangle.

4. Click on Smart Dimension  and click on side edges 
of rectangle to give dimension to the rectangle as 0.59” x 
1.26”.
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5. Click Features>Extruded Boss/Base,  on Direction 1
set D1 to 0.28”.

and .

6. Click on top face of this block and click Normal To.



7. Click on top face again and click Sketch.

8. Click on Line tools and select Centerline,

 sketch a centerline through left edge 
midpoint to right edge midpoint.

9. Click on Line  and sketch a cut section on upper left 
edge as sketched below.

Click on Smart Dimension  and dimension the 
sketch as sketched below.



10. Select cut section sketch

and click on Mirror Entities. 
At its options click on Mirror about: box 

and click on centerline.



and .

11. Click on Features>Extruded Cut  and set Direction 1 to 

Through All and .



12. Rotate the part and click on USB back and click Normal To.

13. Click on this face again and click Sketch.

14. Click on Line tools and select Centerline,

 sketch a centerline through bottom 
edge midpoint to top edge midpoint.



Click Circle  and click on midpoint of centerline as its 
center and sketch a circle.

Click on Smart Dimension  and dimension the 
circle as 0.24”.

15. Click Features>Extruded Boss/Base,  on Direction 1
set D1 to 0.55” and click on taper icon and add draft to 

2deg and .



16. Click on top face of draft and click Sketch.

Click on Circle and sketch circle on the face, to get center 
align to center base, hover your cursor a moment at base 
circle edge, when center of it appear choose it as your new 
circle sketch center.

17. Click on Smart Dimension  and dimension the 
circle as 0.12”.



18. Click Features>Extruded Boss/Base,  on Direction 1

set D1 to 0.80” and .

19. Click on View Orientation and click on Isometric.

20. Click on top face and click on Normal To.



21. Click on top face again and click Sketch.

22. Click on Line tools and select Centerline,

 sketch a centerline through left edge 
midpoint to right edge midpoint.

23. Click on Rectangle tools and select Center Rectangle,

Click on centerline as it center and sketch a rectangle.



24. Click on Smart Dimension  and click on side edges 
of rectangle to give dimension to the rectangle as 0.57” x 
0.39” and 0.16” from right edge.

25. Click on Features>Extruded Cut  and set Direction 1 to 

0.02” and .

26. Click on new cut face and click Sketch.

27. Click on Line tools and select Centerline,

 sketch a centerline through left edge 
midpoint to right edge midpoint.



28. Click Circle  and click on origin.

Click on Smart Dimension  and dimension the 
circle as 0.1”.



29. Click on Offset Entities , click on centerline,

set D to 0.1” and check Bi-directional option and .

30. Click on top line and click Construction Geometry.

Repeat this step for bottom line also.



31. Click Circle  and click on top centerline and sketch a 
circle.

Click on Smart Dimension  and dimension the 
circle as 0.06” and 0.33” distance from left circle.

32. Click on Rectangle tools and select Center Rectangle,

Click on bottom centerline as it center and sketch a 
rectangle.



Click on Smart Dimension  and dimension the 
rectangle as 0.06”x0.06” and 0.33” distance from left circle.

33. Click on Line  and sketch triangle at centerline.

Click Features>Extruded Boss/Base,  on Direction 1
set Up To Surface

select top face (pink face) and .



34. Click on bottom cut face and click Sketch.

Click on Line tools and select Centerline,

 sketch a centerline connecting all the 
symbols.

Click on Offset Entities , set D to 0.01” and check the 
Bi-directional option.



click on all connected centerline and .

Click on Line  and close open end of each end (4x).

Click Trim Entities select Trim to closest 

and trim off excess line from this



to this

and .

35. Click Features>Extruded Boss/Base,  on Direction 1
set Up To Surface

select top face (pink face) and .



36. Click on View Orientation and click on Isometric.

37. Click on left face and click Normal To.

Click on this face again and click Sketch.

38. Click on Line tools and select Centerline,

 sketch a centerline from bottom edge 



midpoint top edge midpoint.

Click on Rectangle tools and select Center Rectangle,

sketch a rectangle from midpoint of centerline.

39. Click on Smart Dimension  and dimension the 
rectangle as 0.16”x0.47”

and . Click on Offset Entities , set D to 0.02”



click on rectangle edge.

and .

40. Click Features>Extruded Boss/Base,  on Direction 1

set D1 to 0.47” and .

41. Click on View Orientation and click on Isometric.

Click on top head left face and click Normal To.



Click on this face again and click Sketch.

42. Click on Line tools and select Centerline,

 sketch a centerline from left midpoint 
edge to right midpoint edge.



Click on Rectangle tools and select Center Rectangle,

sketch a rectangle on the face.

Click on Smart Dimension  and dimension the 
rectangle as 0.10”x0.08” and for its position 0.24” from left 
edge and 0.11” from centerline.



43. Select all entities of rectangle 

and click Mirror Entities 

and on Mirror about: box select centerline and .



44. Click on Features>Extruded Cut  and set Through All

 and .

45. Click on View Orientation and click on Isometric.

Click on front head left face and click Normal To.



Click on this face again and click Sketch.

46. Click Rectangle  and sketch a rectangle on this face.

Click on Smart Dimension  and dimension the 
rectangle height as 0.04”.

Click Features>Extruded Boss/Base,  on Direction 1



set Up To Surface

select top face (pink face) and .

47. Click on View Orientation and click on Isometric.

48. Click on Fillet , set fillet radius to 0.04”

and select main body edge



and .

49. Click on Fillet , set fillet radius to 0.04”

 and select head edges

and .



50. Rotate the pack to view the back end and click Normal To
on top wire guard.

Click on this face again and click Sketch.

Click on Line tools and select Centerline,

 sketch a centerline from top to 
bottom and left to right as sketched.



51. Click Rectangle  and sketch a rectangle on this face.

Click on Smart Dimension  and dimension distance 
between rectangle edge to cross centerline to be as 0.03”.



52. Click on wire edge,

and click Covert Entities , this will project outer 
edge to the face.



53. Click Trim Entities  select Trim to closest 

and trim off excess line from this

to like this



54. Click on Features>Extruded Cut  and set From: Offset
and distance to 0.04” and for Direction 1 set Blind and D1 to 

0.04” and .

The cut should look like this;



If your cut not in correct orientation you can try toggle 

direction of cut by clicking this button. 

55. Click on last extruded cut feature icon tree

 and click on Linear Pattern , for 
Direction 1 click on body edge, set D1 to 0.08” and # to 6

and .



56. Click on LPattern icon tree  and click on 
Linear Pattern>Circular Pattern

on Parameters click wire surface as axis of rotation, # to 4, 

Equal spacing and .



57. Click on View Orientation and click on Isometric.



58. Save  the part as USB head and you’re done! Simple isn’t 
it?
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How to twist phone cord
Learn how to create twist phone cord… with you
mouse



First you need to have spiral, with circle base 2″ , 2
revolution and 2 pitch. Don’t know how? Refer this
tutorial; Tutorial #2: How to create simple spring



Now add a plane at end of spiral, select parallel to
front plane.



Sketch a circle on Plane2, 0.08″ and 0.15 height.

Click Swept Boss/Base.

Select Sketch3 as profile and Helix/Spiral1 as path.

Open up Options and set Twist Along Path, define by
Turns and 50 turns.



And OK you’re done!



How to use Revolved Boss/Base

In this tutorial you will create this part.

1. Click New. Click Part, OK.
2. Click Front Plane and click on Sketch.

3. Select centerline, sketch vertical line

start from origin, roughly 1.5in and OK.



4. Click circle and sketch a circle on left side of the

centerline.

5. Click Smart Dimension, click sketched circle
and set it diameter to 0.75in and add dimension for it

location as below sketch and OK.
6. You just completed your sketch, let’s build feature
from it. ClickFeature>Revolved Boss/Base

7. Click centerline as axis

OK.



8. You’re done!



How to use Revolved Cut

In this tutorial, you will create this part using revolved
feature tools.

1.Click New. Click Part, OK.

2.Click Front Plane and click
on Sketch.

3.Click Rectangle, sketch rectangular.

Click Smart Dimension, dimension
rectangular 3in x 3in.



4.Click Feature>Extruded Boss/Base,
set D1 to 2in

and .

5.Click on front face and click Sketch.

6. Click Circle, and sketch a circle on front face.



7. Click Smart Dimension, dimension sketch as
below sketched.

8.Click Features>Revolved Cut click
on right side edge as axis of revolution,



and .

9. You’re done!



How to use Linear Pattern

In this tutorial, you will create this part.

1.Click New. Click Part, OK.

2.Click Front Plane and click
on Sketch.

3.Click Rectangle, sketch rectangular.

Click Smart Dimension, dimension rectangular
3in x 3in.



4.Click Feature>Extruded Boss/Base,

set D1 to 1.0in and OK.
5. Click on front face and select Normal to.



6.Click front face and Insert Sketch.

7.Click Circle, sketch circle at one edge.

8.Click Smart Dimension, dimension circle as
below sketch.



9.Click Features>Extruded Cut,

set Direction 1, Through All and OK.

10.Click Linear Pattern, click left edge,



on Direction 1 set spacing D1 to 1.0in and Instances
# to 3.

11.Click bottom edge,



on Direction 2 set spacing D2 to 1.0in and Instances
# to 3.

12.Click inside white box Features to Pattern.

Open up part tree, select Extrude 2

and OK.

13.You’re done!




